Blackboard
Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Blackboard Learn LogoImage Removed

Table of Contents

Topic Overview - Browser Support

Blackboard Learn is tested with a variety of technologies.

These browsers work best with our version of Blackboard Learn:

...

Internet Explorer 9 and later

 

Run the browser checker to see

...

whether Blackboard Learn supports your browser

...

Warning
titleInternet Explorer Users

Some configuration options for Internet Explorer may make certain features of Blackboard difficult to use.

Microsoft® Windows® Operating System

...

Windows Version

...

Internet Explorer® 11

...

Internet Explorer® 10

...

Internet Explorer® 9

...

Firefox (Final Release Channel)

...

Chrome (Stable Channel)

...

Windows 7 (32-bit)

...

Unsupported by MS

...

Supported

...

Windows 7 (64-bit)

...

Supported

...

Supported

...

Supported

...

Windows 8 (32-bit)

...

Windows 8 (64-bit)

...

Windows 10 (32-bit)

...

Windows 10 (64-bit)

...

 

Apple® Mac OS® Operating System

...

 Mac Version

...

Safari 8

...

Safari 7

...

Safari 6

...

Firefox (Final Release Channel)

...

Chrome (Stable Channel)

...

Mac OSX 10.7

...

Supported

...

Max OSX 10.8

...

Max OSX 10.9

...

Max OSX 10.10

...

Also add Blackboard (http://blackboard.syr.edu) to your IE Trusted Sites Security.

Configuration Notes

...

.

Blackboard Ultra is tested with a variety of technologies.


Desktop Browser VersionMobile Browser Version
Chrome87+33+
Edge287+46+
Firefox78+33+
Safari13+ (desktop, Mac OS only)On iOS 12+

Technologies Not Supported

The following technologies are not supported in the October 2014 release:

  • Internet Explorer 6, 7, 8Explorer 
  • Firefox 1.x, 2.0, 3.0, 3.5, and 3.6
  • Safari 2, 3, 4, 5, and any version on Windows
  • Windows XP
  • Mac OSX through 10.6
  • JRE 5

 Accessibility and JAWS

Blackboard strives to make all its products as accessible as possible. JAWS for Windows 11 and 12 were used during accessibility testing in SP 11.

JRE Support

JRE (Java Runtime Environment) is not required for users to access and interact with the Learn platform with the exception of the following features and tools:

  • Learn collaboration tools virtual classroom and chat
  • Multiple-file uploads
  • Math equation editor
  • Default text editor shipped with Learn 9.1 SP9 and earlier

Blackboard has tested and supports these features with JRE versions 7 and 8. JRE 6 may work, but could result in unexpected behavior. The JRE can be downloaded from http://www.oracle.com/technetwork/java/javase/downloads/index.html. Windows system administrators who want to provide auto-download for users can find the.cab file link for the appropriate JRE at http://www.oracle.com/technetwork/java/javase/autodownload-140472.html.

...

Blackboard's approach to browser testing

To verify this confidence with each new release, Blackboard executes our browser compatibility test suite against newly released browser versions on multiple OS combinations to ensure function prior to releasing a given version. This testing leverages the full set of automation and manual testing strategies available to ensure confidence in testing.

Newer browser versions

Because of the increased frequency of new browser versions released by some vendors, Blackboard's policy is to support all new browser versions released to the market as Generally Available or by supported release channels, even if the browser is released after testing has concluded for the release. We address any critical browser issues found by clients in the field against a provisionally supported browser as a top priority. We execute frequent test cycles against new browsers to ensure the system continues to perform as expected and will update client facing supported browser documentation appropriately.

Older browsers

Just as we recommend keeping up with the latest version of Blackboard Learn for the best experience, the browser vendors make the same recommendation about their software. Some older versions of browsers from some vendors may have rendering issues with newer versions of Learn, and some newer browser versions may have rendering issues with older versions of Learn.

Blackboard still accepts client issues for these browsers reported to Support and will attempt to replicate the issue on a fully supported browser. If we can't replicate the issue, Blackboard recommends that the client move to a browser version fully supported by Blackboard. In some cases, an additional recommendation might be to update to a more modern version of Learn.

Assistive software and accessibility

For the best Blackboard Learn experience with your screen reader, use ChromeTM and Jaws on a Windows® system. On a Mac® use Safari® and VoiceOver.

Blackboard strives to make all its products as accessible as possible. To learn more about assistive technologies, visit Accessibility at Blackboard or Accessibility for Blackboard Learn with the Ultra Experience.

Java and other browser plugins

A handful of Blackboard Learn features require particular additional software to be installed. Without these, the features themselves won't function. Users may be prompted to install the additional software when accessing these features or, depending on individual browser security settings, users may need to acknowledge a browser message allowing the plugin to run on their system.

If you need information about the specific features that require browser plugins for a particular service pack of Learn or version information for the plugins themselves, see the Release Notes for that release.

Blackboard Learn can be used to serve media content or other types of specialized content that requires a browser plugin such as Java, Flash Player, Apple QuickTime, or other plugins to render the content. In these scenarios, the version of the plugin and the browsers that are compatible with the plugin, as well as installation and configuration instructions for the plugin, are determined by the nature of the content and will vary.

Sources and Relevant Links

For more detail see Blackboard's Browser Support and Blackboard's Browser Support Policy